12 May 2012

(Eclipse) EPICを用いたPerlデバッグで変数ブラウズが出来ない

EclipseプラグインのEPICを用いてPerlのデバッグをしようとすると、”Install PadWalker Perl module to see local variables”というエラーメッセージが表示されて、変数ウォッチすることができない。

■ 検証環境
 Ubuntu 12.04
 Eclipse 3.7.2
 EPIC 0.5.46

root権限でEclipseを起動した場合は特に問題なく変数ウォッチできるのに、なぜ一般ユーザ権限ではできないのか。理由はよくわからないが、libpadwalker-perlをインストールしたら問題解決した。

EPICでPerlデバッグをするときには

cpan PadWalker sudo apt-get install libpadwalker-perl

の2個のモジュールのインストールが必要。下の方は忘れがち…